Erro 1889 no envio do S-2210: comunicação de acidente de trabalho (funcionário)

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1. Este artigo orienta sobre como corrigir a rejeição Erro 1889 - Agente causador inválido no envio do evento S-2210 (comunicação de acidente de trabalho) no sistema SST.

2. O erro ocorre devido a inconsistências no preenchimento do campo Agente causador em relação ao Tipo de acidente selecionado, conforme as regras da versão 1.2 do leiaute do eSocial.

 

Ícone com retângulo e círculo verdes representando o produto Folha de Pagamento.

🎯 Pré-requisitos


 

 

Erro


 

Primeiramente, se certifique que você atende aos Pré-requisitos citados anteriormente. Caso sim, prossiga com a leitura abaixo:

No Gerador Robomatic, o evento S-2210 é retornado com a seguinte mensagem de erro:

Agente causador inválido.
Ação sugerida: O valor informado deve ser um código válido, existente em uma das tabelas 14 (agente causador do acidente de trabalho) ou 15 (agente causador/situação geradora de doença profissional), conforme a data e o código do acidente informados.

Mensagem de erro 1889 no Gerador Robomatic.

 

Causa


 

Com a entrada da versão 1.2 do leiaute do eSocial, os códigos válidos das tabelas 14 e 15 foram atualizados. A validação do código do Agente causador agora depende diretamente do Tipo de acidente informado no cadastro da CAT.

 

Solução


 

  • Passo 1: Acesse o cadastro da CAT: No sistema SST, acesse o menu Comunicações > Comunicação de Acidente de Trabalho CAT.

Menu Comunicação de Acidente de Trabalho CAT

  • Passo 2: Localize o funcionário: Busque e selecione o funcionário que apresentou a rejeição no evento S-2210;
  • Passo 3: Validar os campos do acidente: No cadastro da CAT, analise a relação entre os campos Tipo de acidente e Agente causador.

Campos Tipo de Acidente e Agente Causador no cadastro da CAT.

 

Regras de validação do eSocial

Tabelas de validação do eSocial.

 

  • Passo 4: Salve as alterações: Após ajustar o código do Agente causador conforme as regras acima, clique em Gravar para salvar as alterações no cadastro;
  • Passo 5: Reenvie o evento: Abra o Gerador Robomatic, localize o evento S-2210 reprovado, selecione-o e clique em Reenviar evento reprovado para realizar uma nova sincronização com o eSocial.

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